IT

ALL IT Technology Information

CCNA IPV6 router prtocol and informaction

IPv6

IPv6 is the newest version of internet protocol formulated by the IETF, which helps identify and local endpoint systems on a computer network and route online traffic while addressing the problem of IPv4 address depletion due to prolonged internet use worldwide

EIGRP

1. Router> enable

2. Router # configure terminal

3. Router (config) # ipv6 unicast-routing

4. Router (config) # interface type number

5. Router (config-if) # ipv6 enable

6. Router (config-if) # ipv6 eigrp as-number

7. Router (config-if) # no shutdown

8. Router (config-if) # router eigrp as-IPv6 number

9. Router (config-router) # router-id {ip-address | IPv6} Address

10. Router (config-router) # no shutdown

11. Router (config-router) # exit

12. Router (config) # exit

13. Router # copy run start LINE LINEBREAK linebreak linebreak Steps Explained:

 

hzr(config)#int s0/0

hzr(config-if)#ipv6 add fec0::12:1/112

hzr(config-if)#no shut

hzr(config-if)#ipv6 enable

hzr(config-if)#ipv6 eigrp 10

 

hzr(config)#int f0/0

hzr(config-if)#ipv6 add fec0::35:1/112

hzr(config-if)#no shut

hzr(config-if)#ipv6 enable

hzr(config-if)#ipv6 eigrp 10

 

hzr(config)#ipv6 unicast-routing

 

hzr(config)#ipv6 router eigrp 10

hzr(config-rtr)#router-id 2.2.2.2

hzr(config-rtr)#no shut

 

Same configure on Mumbai router only change as mention

 

mumb(config-rtr)#router-id 1.1.1.1

mumb(config-rtr)#no shut

 

Types of IPV6 to IPV4 Tunnel

1)      Dual Stack

2)      Manual Tunnel

3)      Auto Tunnel

 

Dual Stack: We can assign ipv4 & ipv6 on same interface that is dual stack.

It is usually used for LAN only.

 

Manual Tunnel

R1#sh run

interface Serial0/0

 ip address 170.10.12.1 255.255.255.0

interface Serial0/1

 ip address 170.10.13.1 255.255.255.0

 

router eigrp 1

 network 170.10.0.0

 no auto-summary

!

R2#interface Tunnel0

 no ip address

 ipv6 address FEC0:23::2/112

 ipv6 rip 1 enable

 tunnel source 170.10.12.2

 tunnel destination 170.10.13.3

 tunnel mode ipv6ip

!

interface Serial0/0

 ip address 170.10.12.2 255.255.255.0

 serial restart-delay 0

 no dce-terminal-timing-enable

 

interface FastEthernet1/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0:24::2/112

 ipv6 rip 1 enable

!

router eigrp 1

 network 170.10.0.0

 no auto-summary

!

no ip http server

no ip http secure-server

ip classless

!

!

!

ipv6 router rip 1

 

R3#interface Tunnel0

 no ip address

 ipv6 address FEC0:23::3/112

 ipv6 rip 1 enable

 tunnel source 170.10.13.3

 tunnel destination 170.10.12.2

 tunnel mode ipv6ip

!

interface Serial0/0

 ip address 170.10.13.3 255.255.255.0

 serial restart-delay 0

 no dce-terminal-timing-enable

 

interface FastEthernet1/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0:35::3/112

 ipv6 rip 1 enable

!

router eigrp 1

 network 170.10.0.0

 no auto-summary

ipv6 router rip 1

 

R4#interface Loopback0

 no ip address

 ipv6 address FEC0:4::4/112

 ipv6 rip 1 enable

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0:24::4/112

 ipv6 rip 1 enable

ipv6 router rip 1

 

R5#interface Loopback0

 no ip address

 ipv6 address FEC0:5::5/112

 ipv6 rip 1 enable

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0:35::5/112

 ipv6 rip 1 enable

ipv6 router rip 1

 

 

Verification Command:

R2#sh run | sec int tunnel 0

If there is problem with tunnel then use mention tunnel related issue.

 

#sh run int s0/0

#sh int s0/0

Verify that tunnel is up or down.

 

OSPF

 

OSPFV3

RIP port = 521

Ospfv2 protocol no:89

Eigrp Protocol no:88

 

R1(config)#ipv6 unicast-routing

R1(config)#int s0/0

R1(config-if)#ipv6 ospf 1 area 0

R1(config)#ipv6 router ospf 1

R1(config-rtr)#router-id 1.1.1.1

R1(config)#exit

R1(config)#int  s0/0

R1(config-if)#ipv6 ospf 1 area 0

R1(config-if)#exit

R1(config)#int s0/1

R1(config-if)#ipv6 ospf 1 area 0

R1(config-if)#exit

R1(config)#int lo 0

R1(config-if)#ipv6 ospf 1 area 0

R1(config-if)#exit

 

Same configure on R2 to R5 and take care with area nos.

 

Done….smile.

 

RIP

 

On R1:

 

conf t

hostname R1

int s0/0

ipv6 address fec0:12::1/112

no  shut

exit

int f1/0

ipv6 address fec0:14::1/112

no  shut

exit

end

 

On R2:

 

conf t

hostname R2

int s0/0

ipv6 address fec0:12::2/112

no  shut

exit

int s0/1

ipv6 address fec0:23::2/112

no  shut

exit

end

 

On R3:

 

conf t

hostname R3

int s0/0

ipv6 address fec0:23::3/112

no  shut

exit

int f1/0

ipv6 address fec0:35::3/112

no  shut

exit

end

 

 

On R4:

 

conf t

hostname HOST-1

int f1/0

ipv6 address fec0:14::4/112

no  shut

exit

 

On R5:

 

conf t

hostname HOST-2

int f1/0

ipv6 address fec0:35::5/112

no  shut

end

 

 

 

====================================

 

Configure RIPng:

 

on R1:

 

conf t

ipv6 unicast-routing

int s0/0

ipv6 rip 1 enable

exit

int f1/0

ipv6 rip 1 enable

exit

ipv6 router rip 1

 

On R2:

conf t

ipv6 unicast-routing

int s0/0

ipv6 rip 1 enable

exit

int s0/1

ipv6 rip 1 enable

exit

ipv6 router rip 1

 

On R3:

conf t

ipv6 unicast-routing

int s0/0

ipv6 rip 1 enable

exit

int f1/0

ipv6 rip 1 enable

exit

ipv6 router rip 1

 

 

ALL

ripng

 

r1(config)#ipv6 router rip 1

r1(config)#int s0/0

r1(config-if)#ipv6 rip 1 enable

 

 

eigrpv6

r1(config)#ipv6 router eigrp 1

r1(config-rtr)#router-id 1.1.1.1

r1(config)#int s0/0

r1(config-if)#ipv6 eigrp 1 enable

 

ospfv3

r1(config)#ipv6 router ospf 1

r1(config-rtr)#router-id 1.1.1.1

r1(config)#int s0/0

r1(config-if)#ipv6 ospf 1 area 0

 

R1:

en

config t

int s0/0

ip add 170.10.12.1 255.255.255.0

no shut

exit

int s0/1

ip add 170.10.13.1 255.255.255.0

no shut

exit

router eigrp 100

network 170.10.0.0

no auto-summary

exit

R2:

en

config t

int s0/0

ip add 170.10.12.2 255.255.255.0

no shut

exit

 

router eigrp 100

network 170.10.0.0

no auto-summary

exit

R3:

en

config t

int s0/0

ip add 170.10.13.3 255.255.255.0

no shut

exit

router eigrp 100

network 170.10.0.0

no auto-summary

exit

____________________________

IPV6 on R2:

en

config t

  ipv6 unicast-routing

 int f1/0

  ipv6 address fec0:24::2/112

  ipv6 rip 1 enable

no shut

  exit

R3:

en

config t

  ipv6 unicast-routing

 int f1/0

  ipv6 address fec0:35::3/112

  ipv6 rip 1 enable

no shut

  exit

R4:

 ipv6 unicast-routing

  int f0/0

  ipv6 address fec0:24::4/112

  ipv6 rip 1 enable

  no shut

  exi

  int loopback 0

  ipv6 address fec0:4::4/112

  ipv6 rip 1 enable

  exit

R5:

 ipv6 unicast-routing

  int f0/0

  ipv6 address fec0:35::5/112

  ipv6 rip 1 enable

  no shut

  exi

  int loopback 0

  ipv6 address fec0:5::5/112

  ipv6 rip 1 enable

  exit

__________________________________________________

Tunnel Configuration on R2:

R2:

en

config t

 int tunnel 0

  tunnel source s0/0

  tunnel destination 170.10.13.3

  tunnel mode ipv6ip

ipv6 rip 1 enable

  ipv6 address fec0:23::2/112

  exit

R3:

en

config t

 int tunnel 0

  tunnel source s0/0

  tunnel destination 170.10.12.2

  tunnel mode ipv6ip

  ipv6 address fec0:23::3/112

ipv6 rip 1 enable

  exit

 

 

for testing :

R4:

R4#ping fec0:5::5 source loopback 0

R5:

R5#ping fec0:4::4 source loopback 0

R2:

R2#sh int tunnel 0

 

 

 

 

 

 

 

EIGRP

hzr#sh run

 

hostname hzr

 

ipv6 unicast-routing

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0::35:1/112

 ipv6 enable

 ipv6 eigrp 10

 

 

interface Serial1/0

 no ip address

 ipv6 address FEC0::12:1/112

 ipv6 enable

 ipv6 eigrp 10

 serial restart-delay 0

 

ipv6 router eigrp 10

 router-id 2.2.2.2

 no shutdown

 

hzr#

 

 

mum#sh run

hostname mum

 

ipv6 unicast-routing

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address FEC0::23:1/112

 ipv6 enable

 ipv6 eigrp 10

 

interface Serial1/0

 no ip address

 ipv6 address FEC0::12:2/112

 ipv6 enable

 ipv6 eigrp 10

 serial restart-delay 0

ipv6 router eigrp 10

 router-id 1.1.1.1

 no shutdown

 

mum#

 

 

 

 

 

 

IPV6

1970 ipv4 developed.

DoD developed. ARPANET known.

1992 ipv6 introduce.

Security inbuit in ipv6(header level)

 

Ipv6 forum….explore it…….

 

Oct2010 ipv4 pool is finished.

 

2000::/3

2 means 001000000000::0000===2000

                001100000000::0000===3fff:ffff:…..

 

Unassigned add-à  ::/0

Loopback addà ::1

Ipv6 to ipv4 communication à 2002::/16

Multicast à ff00::/16

 

Ipv6  address assigned method:

1)      Manaual – static address

EUI – 64 bits Method (Extendable user interface)

2)      Auto Configuration – stateless autoconfig

         Stateful autoconfig

 

How to Stop ND (network Discovery)

To stop ND process in ipv6

R1(config)#int fa0/0

R1(config)#ipv6 nd suppress-ra

 

 

 

 

 

 

 

==

 

 

To view ipv6 address assigned to interfaces

#sh ipv6 int brief

 

To view the ipv6 routing table

#sh ipv6 route

 

Whenever you assign the ip address to any perticaular interface than first "no shut"

the fast ethernet.

 

because of the fastethernet,link-local address will be generated.

#int f1/0

#no ip add

#no shut

#exit

#int s0/0

#ipv6 add fec0::12:1/112

#no shut

#exit

#sh ipv6 int brief

 

 

 

5 comments: